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Have you ever tried to create an 
index in Word? Were you dissatis-
fied with the options available in the 
dialogs? There are other features 
available that can provide you with a 
higher level of control over the struc-
ture of the index. This article gives 
you an overview of advanced index-
ing techniques; see Word’s online 
help for details. The menu sequences 
are for Word 2000; there are slight 
differences in Word 2002.

How indexing works
An indexer puts a marker (also 
known as a code or a tag) in the body 
of a document. Software then gener-
ates the index using the entries, as 
shown in Figure 1.

In Word’s terminology, the term 
index entry can refer to:
l A code in the text (the most 

common meaning), implemented as 
an XE field

l A heading or subheading in the 
index (for example, ‘animals’ or 
‘cats’)

l A heading and its locators in the 
index (for example, ‘animals, 1-3’)

In Word’s online help the context 
should make the terminology clear, 
and you should not have any prob-
lems understanding what is meant. 
Since an index entry (marker) is 
technically a Word field, an index 
entry is also known as an index entry 
field.

Overview of techniques
To create an index entry (XE field) 
you can use:
l The Mark Index Entry dialog. 

This is the elementary method. It’s 
got lots of help, but it’s laborious 
and doesn’t give all options. We 
won’t be looking at this.

l The Field dialog. This enables you 
to use all the options.

l A concordance file. Word inserts 
index entries for the words 
contained in the concordance file. 
This is useful sometimes, but a 
concordance and an index are not 

the same. You’ll probably spend 
more time reworking the index 
entries than you would if you just 
entered them manually. We won’t 
be looking at this.

Word uses the index entries to build 
the index (an INDEX field). To create 
an index you can use:
l The Index and Tables dialog. This 

does not give you access to all the 
options. We won’t be looking at this.

l The Field dialog. This enables you 
to use all the options.

After you add, delete or modify index 
entries, or add or remove text in 
the document, you must update the 
index to reflect the changes. To do 
this, put the cursor anywhere in the 
index and press F9.

To work with Word’s fields, you 
need to see what’s going on behind 
the scenes by viewing hidden text. 
To do this, choose Tools>Options. 
The Options dialog appears. On the 
View tab, select (as a minimum) 
bookmarks, field shading and all 
formatting marks. Select OK.

Inserting an index entry
To insert an index entry, put the cur-
sor where you want the index entry 
to appear. Choose Insert>Field. 
The Field dialog appears. In the 
Categories list, select Index and 
Tables. The Field names list appears. 

Select XE. Type the text for the index 
entry in the box at the bottom of 
the dialog (if the text contains more 
than one word, you must enclose it in 
double quote marks). Figure 2 shows 
an example.

Choose OK. The index entry appears 
in the document, as shown in Figure 3.

In a typical index, a single heading has 
many locators. A quick way of insert-
ing an index entry is to copy and paste 
it.

Word workarounds

Automating your Word indexes
Microsoft® Word has powerful tools for indexing. Mike Unwalla guides you 
through the process of creating and modifying an index using fields.

Figure 1. Generic indexing concepts

Figure 2. Field

Figure 3. Index entry (field)
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Word workarounds

Editing an index entry
At some stage, you will need to edit 
an index entry. You can change any 
of the text that is between the field 
markers { and }. If you accidentally 
remove a quote mark, don’t worry, 
just re-type it.

An index entry can be more com-
plex than that shown in Figure 3, 
and can incorporate field switches 
that control various options. To edit 
index entries, you need to know what 
the field switches mean. Table 1 
explains the most common options.
Figure 4 shows an example index 
based on the entries in Table 1.

You can combine some switches. For 
example, { XE "rabbits" \i \b } would 
result in a bold italicised locator.

Beware that although Word lets 
you put an index entry in a text box, 
the index entry won’t be used to 
build the index.

Creating an index
To create an index, put the cursor 
where you want the index to appear. 
Choose Insert>Field. The Field 
dialog appears. In the Categories list 
select Index and Tables. The Field 
names list appears and the Index 
field is automatically selected (it’s 
first in the list). Choose Options. 
The Field Options dialog appears.

Add the switches that control the 
index structure. For example, the 
default separator for a page range is 
an n-dash, so headings in the index 
would be of the form ‘animals 1–10’. 
You can specify another separator, 
for example, you might want the 
form ‘animals 1 to 10’ (see Figure 5). 
Choose OK>OK.
The index structure shown in Figure 
4 is based on the field:
{ INDEX \h "A" \c "2" \g " to " }. 
This creates an index with heading 

letters (display letters), two columns 
and a page range that is indicated 
using the word ‘to’.

To modify the structure of an exist-
ing index, change the switches and 
the text in the INDEX field.

The appearance of the items of 
text in the index, such as point 
size, colour and spacing between 
lines is defined by the styles used 
(Format>Style). Table 2 shows the 

most common ones.
It is not practical to modify the text 

or formatting in an index directly, 
because changes are lost when you 
update the index. However, you can 
apply text formatting to an index 
entry itself (for example, font colour 
or highlight), and this will appear in 
the final index.

Sometimes you need to see the 
INDEX field, and sometimes you 
need to see the resultant index. You 
can right-click in the field (or index) 

and click Toggle Field Codes, but a 
quicker method is to use Shift + F9.

Indexing multiple documents
You can create a single index for 
two or more Word documents using 
the RD field (Referenced Document 
field). The index itself could be in an 
entirely separate document (this is 
often the simplest approach), or it 
could be in one of the existing docu-

ments. The documents need not be 
in the same folder. Ensure that page 
numbering starts correctly in each 
document (it is not necessary to 
display the page number), otherwise 
the numbering in the index will be 
wrong.

To create an index that combines 
entries from more than one docu-
ment, close all the documents except 
the one in which you want the index 

Table 1. Index structure and switches

Element of index Controlled by style

Word or phrase as a 
heading

{ XE "cats" }
A basic entry consists of one or more words enclosed in quote marks. A single 
word does not need quote marks.

Subheading { XE "animals:cuddly" }
Use a colon to create a subheading. You can have up to six subheading levels.

Cross-reference { XE "mammals" \t "See animals" }
Use the \t switch to create a cross-reference (no locator is displayed in 
the index). The text can be anything, and need not be italicised, though by 
convention, it is.

Bold locator { XE "cats" \b }
Use the \b switch to format the locator as a bold character.

Italic locator { XE "camel (picture)" \i }
Use the \i switch to format the locator as an italic character.

Page range { XE "animals" \r "animals_chapter" }
Use the \r switch to define a page range. The text following the switch must be 
the name of a bookmark.

Figure 4. Example index Figure 5. Field options

Table 2. Word styles for index formatting

Element of index Controlled by style

heading Index 1

subheading Index 2

display letter (heading letter) Index Heading
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(you shouldn’t have to do this, but 
sometimes Word doesn’t generate the 
index correctly if you don’t).

Open the Field dialog 
(Insert>Field). In the Categories 
list select Index and Tables. The 
Field names box appears. Select RD. 
The fi eld appears in the box at the 
bottom. The switch that indicates a 
referenced fi le is \f, so type this (or 
choose Options to add the switch) 
followed by the fi le name of the fi rst 
document you want to include. If the 
fi lename contains spaces, enclose 
the name in double quote marks. 
Do not include the document that 
contains the index in the list of ref-
erenced documents.

Choose OK>OK. Word creates the 
RD fi eld. Rather than repeating this 
process for each of the documents 
that you want to reference, copy and 
paste the fi eld and then edit it. The 
RD fi elds must physically be in the 
same sequence as the documents 
themselves, otherwise the order 
of the locators will be wrong. For 
example, you might have an entry 
‘cats 3, 17, 5’.

Insert the index. If all you want is 
a basic index, copy and paste the RD 
fi eld and then edit it. When you edit 
your RD fi eld to INDEX, it changes 
colour to grey. You might see some-
thing like the example shown in 
Figure 6.

Right-click on the INDEX fi eld 
and click Update Field. The com-
bined index appears.

RD fi elds can sometimes go awry. 
You can usually solve the problem 
by shutting down Word and then re-
starting. If this doesn’t help, delete 
and re-insert the RD fi elds.

Modifying the sort order
The default sort order (alphabeti-
sation) in a Word index is word by 
word. Occasionally, we want letter-by-
letter sorting, as shown in Table 3.

To force letter-by-letter alphabetisa-
tion, if a heading (or subheading) 
contains a space, insert a semi-colon 
at the end of the text for a heading, 
and follow it by the text with all the 
spaces omitted. For example:
{ XE "data records;datarecords" }.

Capitalisation affects the sort 
order, as does white space.

Multiple indexes
Occasionally, it’s useful to have 
more than one index (in index-
ing terminology, this is known as 
having multiple sequences). For 
example, in a software manual 
you may want a separate index for 
screen names. You can do this using 
the \f switch (this has nothing to do 
with the \f switch in RD fi elds).

To create another index, fi rst choose 
a convenient identifi er. Create or 
modify each index entry so that it 
contains the \f switch followed by 
the identifi er. For example, an index 
entry might look like this: { XE 
"Mark Index Entry" \f "screens" }. 
To create the index, ensure that the 
INDEX fi eld uses the same identifi er, 
for example:
{ INDEX \f "screens" }.

There is no limit to the number of 
indexes; each index can be located 
anywhere in the document and 
you can use all the other INDEX 
switches.

Location of cross-references
Where should cross-reference index 
entries be located in a document?

One option is to put a cross-ref-
erence index entry near the fi rst 
occurrence of the related index entry, 
but this can become confusing.

A better option is to put them 
all together at some convenient 
location in the document. If you 
put each index entry in a sepa-
rate paragraph you can sort them 
alphabetically (which simplifi es 
editing). However, from a purist’s 
perspective, it’s poor practice to 
have empty paragraphs that don’t 
contain printable text. Also, if there 
isn’t enough white space in the 
document, the pagination becomes 
upset (you could put all the entries 
in a single paragraph, but it gets 
cluttered, and you can’t sort the 
entries).

Another option is to put the index 
entries in a separate document and 
use the RD fi eld to use the entries 
for building the index. You can put 
each entry in a separate paragraph, 
so you can sort them alphabetically. 
Since the document is separate from 
the main text, you can put your own 
notes and comments in it. A disad-
vantage is that you have an extra 
document with which to deal. 

Dr Mike Unwalla MISTC has been 
documenting software products since 
1994. He has been a freelance writer 
since 1999. He is a member of the 
Society of Indexers.
E-mail: mike@techscribe.co.uk
Website: www.techscribe.co.uk

Word workarounds

Table 3. Sort order

Word by word Letter by letter

data data
data records database
database data records
dates dates

Figure 6. Index entry (field)
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